Security Advisory

Insider Threat Management Server Remote Code Execution Vulnerabilities

Advisory ID: PFPT-SA-2020-0003
Advisory Version: 1.0
First Published: May 11, 2020

Summary

Proofpoint Insider Threat Management Server (formerly ObserveIT Server) contains multiple remote code execution vulnerabilities. A remote attacker could exploit these vulnerabilities to execute arbitrary code with local administrator privileges.

Proofpoint has released fixed software versions that address these vulnerabilities. See the Fixed Software section below.

Affected Versions

All versions of Proofpoint Insider Threat Management Server prior to 7.9.1 are affected by these vulnerabilities. Proofpoint Insider Threat Management Server version 7.9.1 includes the fix, so no action is required by customers already running that version. Otherwise, updating to a fixed version is highly recommended.

Vulnerabilities

CVE-2020-10655 - Remote Code Execution in Insider Threat Management Application Server WriteWindowMouse API
CVSS: 9.8 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
Proofpoint Insider Threat Management Server versions before 7.9.1 contain a vulnerability in the application server's WriteWindowMouse API. The vulnerability allows an unauthenticated remote attacker to execute arbitrary code with local administrator privileges. The vulnerability is caused by improper deserialization.

CVE-2020-10656 – Remote Code Execution in Insider Threat Management Application Server WriteWindowMouseWithChunksV2 API
CVSS: 9.8 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
Proofpoint Insider Threat Management Server versions before 7.9.1 contain a vulnerability in the application server's WriteWindowMouseWithChunksV2 API. The vulnerability allows an unauthenticated remote attacker to execute arbitrary code with local administrator privileges. The vulnerability is caused by improper deserialization.

CVE-2020-10657 – Remote Code Execution in Insider Threat Management Web Console
CVSS: 7.2 (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H)
Proofpoint Insider Threat Management Server versions before 7.9.1 contain a vulnerability in the web console's ImportAlertRules feature. The vulnerability allows an authenticated remote attacker with admin or config-admin privileges in the console to execute arbitrary code with local administrator privileges. The vulnerability is caused by improper deserialization.

CVE-2020-10658 – Remote Code Execution in Insider Threat Management Application WriteImage API
CVSS: 9.8 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
Proofpoint Insider Threat Management Server versions before 7.9.1 contain a vulnerability in the application server's WriteImage API. The vulnerability allows an unauthenticated remote attacker to execute arbitrary code with local administrator privileges. The vulnerability is caused by improper deserialization.

Fixed Software

Proofpoint has released fixed software versions 7.5.3, 7.6.4, 7.7.4, 7.8.3, and 7.9.1
The fixed software versions are now available through the customer support portal.
https://observeit.force.com/support/s/login/

URL

https://www.proofpoint.com/us/security/security-advisories/pfpt-sa-2020-0003

Revision History

Version Description Section Date
1.0 Initial release   May 11, 2020

Legal Disclaimer

THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS AT YOUR OWN RISK. PROOFPOINT RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.

A standalone copy or paraphrase of the text of this document that omits the distribution URL is an uncontrolled copy and may lack important information or contain factual errors. The information in this document is intended for authorized subscribers to Proofpoint products and services.

Questions or concerns?

Open a Support call or contact Support via your hotline phone number. Further updates will be posted as needed.